Thunderbird aktualisieren


Auf der Thunderbird-Webseite kann man nachsehen, ob eine neue Version verfügbar ist.

Als root Thunderbird ausführen und Menü Help -> Check for Updates... bzw. Hilfe -> Thunderbird aktualisieren... aufrufen.

Die in Slackware 12.2 enthaltene Thunderbird-Version lässt sich problemlos auf die jeweils aktuelle Version aktualisieren.


Thunderbird in deutscher Sprache


Auf der Webseite ftp://ftp.mozilla.org/pub/thunderbird/releases/ das Verzeichnis für die aktuell installierte Thunderbird-Version öffnen, dann weiter im Unterverzeichnis ./linux-i686/xpi/ die Datei de.xpi herunterladen.
Danach in Thunderbird Menü Tools -> Add-ons -> Languages -> Install... aufrufen, die Datei de.xpi installieren, und Thunderbird neu starten.

Das zu den Emails angezeigte Datums- und Uhrzeitformat wird davon nicht beeinflusst.
Um das deutsche Datums- und Uhrzeitformat einzustellen siehe SlackwareInDeutscherSprache.

oder optional die deutsche Thunderbird-Version installieren:

Einfach die deutsche Version von Thunderbird von http://www.mozillamessaging.com/de/ herunterladen, entpacken, und das Verzeichnis Thunderbird nach /opt kopieren.
Danach kann der Emailclient mit /opt/thunderbird/thunderbird gestartet werden.


Thunderbird-Einstellungen aus einer vorherigen Installation übernehmen


Ein möglicher Weg:
  1. Zuerst in Thunderbird ein beliebiges (Dummy-) Email-Konto anlegen und Thunderbird beenden.
  2. Im Home-Verzeichnis in ~/.thunderbird nachschauen, wie das neue Profil heißt (*.default)
  3. Das alte Profil suchen, bei Ubuntu z. B. liegt es in ~/.mozilla-thunderbird, dieses nach ~/.thunderbird kopieren und entsprechend umbenennen.


Dateianhänge öffnen


Wenn Thunderbird Office-Dokumente nicht erkennt bzw. nicht nach einem passenden Anwendungsprogramm fragt, kann man fehlende Einträge in der Liste der Standard-Aktionen (BearbeitenEinstellungenAnhängeStandard-Aktionen) in der Datei ~/.thunderbird/<Profilname>.default/mimeTypes.rdf von Hand nachtragen.


Mit den folgenden xml-Tags sinngemäß in die Datei ~/.thunderbird/<Profilname>.default/mimeTypes.rdf ergänzt, werden dann OpenDocument-Dateien sowie Microsoft® Office- und Staroffice-Dokumente standardmäßig mit OpenOffice.org geöffnet.

Nach dem xml-Kopf:

<?xml version="1.0"?>
<RDF:RDF xmlns:NC="http://home.netscape.com/NC-rdf#" <RDF:Description RDF:about="urn:mimetypes">
<NC:MIME-types RDF:resource="urn:mimetypes:root"/>
</RDF:Description>

einen passenden MIME-Typ gemäß /usr/share/mime/types angeben:

<RDF:Description RDF:about="urn:mimetype:handler:application/vnd.oasis.opendocument.text"
NC:alwaysAsk="false"
NC:useSystemDefault="false"
NC:saveToDisk="false">
<NC:externalApplication RDF:resource="urn:mimetype:externalApplication:application/vnd.oasis.opendocument.text"/>
</RDF:Description>

Die Beschreibung zum MIME-Typ und die Liste der Dateiendungen angeben:

<RDF:Description RDF:about="urn:mimetype:application/vnd.oasis.opendocument.text"
NC:value="application/vnd.oasis.opendocument.text"
NC:editable="true"
NC:description="Office Document">
<NC:fileExtensions>odt</NC:fileExtensions>
<NC:fileExtensions>ott</NC:fileExtensions>
<NC:fileExtensions>csv</NC:fileExtensions>
<NC:fileExtensions>doc</NC:fileExtensions>
<NC:fileExtensions>docm</NC:fileExtensions>
<NC:fileExtensions>docx</NC:fileExtensions>
<NC:fileExtensions>dot</NC:fileExtensions>
<NC:fileExtensions>dotm</NC:fileExtensions>
<NC:fileExtensions>dotx</NC:fileExtensions>
<NC:fileExtensions>odb</NC:fileExtensions>
<NC:fileExtensions>odf</NC:fileExtensions>
<NC:fileExtensions>odg</NC:fileExtensions>
<NC:fileExtensions>odm</NC:fileExtensions>
<NC:fileExtensions>odp</NC:fileExtensions>
<NC:fileExtensions>ods</NC:fileExtensions>
<NC:fileExtensions>otg</NC:fileExtensions>
<NC:fileExtensions>oth</NC:fileExtensions>
<NC:fileExtensions>otp</NC:fileExtensions>
<NC:fileExtensions>ots</NC:fileExtensions>
<NC:fileExtensions>pot</NC:fileExtensions>
<NC:fileExtensions>potm</NC:fileExtensions>
<NC:fileExtensions>potx</NC:fileExtensions>
<NC:fileExtensions>pps</NC:fileExtensions>
<NC:fileExtensions>ppt</NC:fileExtensions>
<NC:fileExtensions>pptm</NC:fileExtensions>
<NC:fileExtensions>pptx</NC:fileExtensions>
<NC:fileExtensions>rtf</NC:fileExtensions>
<NC:fileExtensions>sda</NC:fileExtensions>
<NC:fileExtensions>sdc</NC:fileExtensions>
<NC:fileExtensions>sdd</NC:fileExtensions>
<NC:fileExtensions>sdp</NC:fileExtensions>
<NC:fileExtensions>sdw</NC:fileExtensions>
<NC:fileExtensions>sgf</NC:fileExtensions>
<NC:fileExtensions>sgl</NC:fileExtensions>
<NC:fileExtensions>sgv</NC:fileExtensions>
<NC:fileExtensions>smf</NC:fileExtensions>
<NC:fileExtensions>stc</NC:fileExtensions>
<NC:fileExtensions>std</NC:fileExtensions>
<NC:fileExtensions>sti</NC:fileExtensions>
<NC:fileExtensions>stw</NC:fileExtensions>
<NC:fileExtensions>svm</NC:fileExtensions>
<NC:fileExtensions>sxc</NC:fileExtensions>
<NC:fileExtensions>sxd</NC:fileExtensions>
<NC:fileExtensions>sxg</NC:fileExtensions>
<NC:fileExtensions>sxi</NC:fileExtensions>
<NC:fileExtensions>sxm</NC:fileExtensions>
<NC:fileExtensions>sxw</NC:fileExtensions>
<NC:fileExtensions>vor</NC:fileExtensions>
<NC:fileExtensions>wb2</NC:fileExtensions>
<NC:fileExtensions>wpd</NC:fileExtensions>
<NC:fileExtensions>xlc</NC:fileExtensions>
<NC:fileExtensions>xlm</NC:fileExtensions>
<NC:fileExtensions>xls</NC:fileExtensions>
<NC:fileExtensions>xlsb</NC:fileExtensions>
<NC:fileExtensions>xlsm</NC:fileExtensions>
<NC:fileExtensions>xlsx</NC:fileExtensions>
<NC:fileExtensions>xlt</NC:fileExtensions>
<NC:fileExtensions>xltm</NC:fileExtensions>
<NC:fileExtensions>xltx</NC:fileExtensions>
<NC:fileExtensions>xlw</NC:fileExtensions>
<NC:handlerProp RDF:resource="urn:mimetype:handler:application/vnd.oasis.opendocument.text"/>
</RDF:Description>

Zu den Standard-Aktionen die Reihenfolge der Listeneinträge festlegen:

<RDF:Seq RDF:about="urn:mimetypes:root">
<RDF:li RDF:resource="urn:mimetype:application/vnd.oasis.opendocument.text"/>

</RDF:Seq>

Nun noch den Pfad zum Anwendungsprogramm angeben. Die Unterscheidung zwischen den Dokument-Typen übernimmt OpenOffice.org automatisch:

<RDF:Description RDF:about="urn:mimetype:externalApplication:application/vnd.oasis.opendocument.text"
NC:prettyName=""
NC:path="/opt/openoffice.org3/program/soffice" />

Ende der xml-Datei:

</RDF:RDF>


Termin- und Aufgabenverwaltung in Thunderbird


Für die Termin- und Aufgabenverwaltung mit Thunderbird kann das Thunderbird-Add-on Lightning installiert werden.


Kategorien


CategoryTipps
Valid XHTML :: Valid CSS: :: Powered by WikkaWiki