Wiki source for OpenOffice21


Show raw source

~- Slackware 12.2
~- Slackware 13

[[http://www.openoffice.org OpenOffice.org]] (engl.) ist ein freies Office-Paket, das aus einer Kombination verschiedener Programme zur Textverarbeitung, Tabellenkalkulation, Präsentation und zum Zeichnen besteht. Ein Datenbankprogramm und ein Formeleditor sind ebenfalls enthalten.


======Manuelle Installation aus RPMs======

=====""OpenOffice.org 2"" aus den RPMs installieren=====

(der einfachste, aber vielleicht nicht der beste Weg)

**Hinweis:**
Wenn schon mal eine manipulierte ""OpenOffice.org-Version"" installiert war (gilt insbesondere für die Ubuntu-Version von ""OpenOffice.org""), wird empfohlen im home-Verzeichnis die Datei //~/.openoffice.org// durch umbenennen, verschieben oder löschen unkenntlich zu machen. Anderenfalls kann nach der Installation der Programmstart eines Moduls (Writer, Calc, ...) in endlosen Dokumentwiederherstellungsversuchen abstürzen.

Leider wird Open Office nur noch als RPM oder DEB angeboten. Mit beidem kann man als Slackware Benutzer nicht wirklich viel Anfangen. Zum Glück gibt es aber nützliche kleine Programme die uns doch den Einsatz von rpm-Paketen auch ohne rpm ermöglichen.

Als erstes natürlich Open Office von hier laden: [[http://de.openoffice.org/downloads/quick.html http://de.openoffice.org/downloads/quick.html]]
Dort als gewünsches System "Linux x86 (rpm)" wählen. Aktuelle Version und Server deiner Wahl.

Nun zunächst als root einloggen (am besten erst mit Strg + Alt + F6 auf ein VT wechseln) und in das Verzeichnis wechseln, in dem z. B. die Datei OOo_2.1.0_LinuxIntel_install_de.tar.gz liegt. Den Inhalt der Datei auspacken (##tar -xfz OOo_2.1.0_LinuxIntel_install_de.tar.gz##). Jetzt hat man ganz viele rpm-Dateien.

Der nächste Schritt ist ein (manchmal) nützliches kleines Slackware Programm, rpm2tgz. ;) Mit einem einfachen "##rpm2tgz *.rpm##" werden jetzt aus all den rpm-Dateien Slackware Pakete erstellt.

Als nächstes kann man die rpm-Dateien mit "##rm *.rpm##" löschen.

Nun mit ##installpkg *.tgz## die ganzen Pakete installieren lassen. Open Office wird dann nach /opt/openoffice.org2.1/ installiert.

Für den schnellen Aufruf von der Konsole lohnt ein Symlink nach /usr/bin:
##ln -s /opt/openoffice.org2.1/program/soffice /usr/bin##

Je nach Windowmanager oder Desktop können jetzt noch Verküpfungen angelegt werden.
Die Startdateien von Open Office, zu denen man dann Verknüpfungen anlegen kann, findet man in /opt/openoffice.org2.1/program/

soffice - Open Office Starter
swriter - Open Office Write (Textverarbeitung)
scalc - Open Office Calc (Tabellenkalkulation)
sdraw - Open Office Draw (Vektorgrafik ?)
simpress - Open Office Impress (Präsentatitionen)
sbase - Open Office Base (Datenbank)
smath - Open Office Math (Formeleditor ?)

Zuletzt können dann noch die erstellten tgz-Dateien wieder gelöscht werden. :) Ob wirklich alle Pakete benötigt werden habe ich nicht geprüft. Heutige Festplatten sollten das unnötige Plus verkraften.


=====Nachtrag zu ""OpenOffice.org 3""=====

Das Installationstutorial trifft auch auf ""OpenOffice.org 3"" zu.
Für ""OpenOffice.org 3"" wird laut offizieller [[http://de.openoffice.org/doc/setupguide/index.html Installationsanleitung]] JRE (Java-Runtime-Environment) Version 1.6.0 oder höher empfohlen. Diese ist im jeweils aktuellen Download-File //Linux x86 (inkl JRE + Installer)// bereits enthalten.

""OpenOffice.org 3"" wird nach ## /opt/openoffice.org3/ ## installiert.


=====""OpenOffice.org"" aktualisieren=====

In OOo Menü **Extras ""→"" Optionen ""→ OpenOffice.org →"" Online Update** kann die automatische Suche nach Updates aktiviert, und das Download-Zielverzeichnis z. B. auf ## /tmp ## eingestellt werden.

Danach kann von dort, oder von OOo Menü **Hilfe ""→"" Suche nach Updates** die Suche gestartet werden.

Zur Installation des Updates siehe oben "Manuelle Installation aus RPMs".
(direkt aus dem Online-Update-Dialog heraus funktioniert die Installation nicht.)



======Installation mit Hilfe eines ""SlackBuild""-Skriptes======

Auf http://www.slackbuild.org/ gibt es ein geeignetes Skript, um aus den RPMs ein anständiges Slackware-Paket zu bauen:

http://www.slackbuilds.org/repository/office/openoffice.org/


======""OpenOffice.org"" mit anderen Anwendungsprogrammen verwenden======

=====Email-Programm zum Versenden von Dokumenten als Anhang einstellen=====

In OOo Menü **Extras ""→"" Optionen ""→"" Internet ""→"" Email** als Email-Programm je nach gewünschtem Email-Programm z. B. ## kmail ## oder ## thunderbird ## eintragen.


=====Adressbuch anmelden=====

====Thunderbird-Adressbuch anmelden====

In OOo Menü **Vorlagen und Dokumente ""→"" Verwalten ""→"" Adressbuch ""→"" Adressdatenquelle ""→"" Thunderbird** wählen. Danach Tabelle auswählen und die Feldzuordnungen bearbeiten.

====KDE-Adressbuch anmelden====

In OOo Menü **Vorlagen und Dokumente ""→"" Verwalten ""→"" Adressbuch ""→"" Adressdatenquelle ""→"" KDE Adressbuch** wählen. Danach Tabelle auswählen und die Feldzuordnungen bearbeiten.

**Siehe auch:** [[http://www.ooowiki.de/AdressBuch Adressbuch anmelden]] in ooowiki.de


=====JDBC-Treiber anmelden=====

**Voraussetzung für die Anmeldung des JDBC-Treibers:** JdbcTreiberInstallieren

In OOo Menü **Extras ""→"" Optionen ""→"" ""OpenOffice.org"" ""→"" Java ""→"" Class Path** die Datei (Java-Archiv) ## /usr/lib/java/lib/ext/mysql-connector-java-5.1.8-bin.jar ## hinzufügen.

Danach ""OpenOffice.org"" komplett beenden und neu starten.


=====""MySQL""-Datenbank anmelden=====

**Voraussetzung für die Anmeldung einer ""MySQL-Datenbank"":** MySQLinBetriebNehmen

In ""OpenOffice.org"" **Modul Datenbank ""→"" JDBC** aufrufen. Dort eingeben:

Datenquellen-URL: ## jdbc:mysql://localhost/<Datenbankname> ##
JDBC-Treiberklasse: ## com.mysql.jdbc.Driver ##

Falls beim Verbindungstest der JDBC-Treiber nicht geladen werden kann, dann sollten die Schritte JDBC-Treiber anmelden und ""MySQL-Datenbank"" anmelden zuerst als root ausgeführt werden. Danach klappt es auch als normaler User.

Anschließend noch auf der nächsten Seite die Authentifizierungsdaten eingeben.


======Siehe auch======

LibreOffice


======Links======

http://de.openoffice.org/ - Deutsche Projektseite
[[http://de.openoffice.org/downloads/komponenten.html Zusätzliche Komponenten]] - Vorlagen, Dokumentation, Rechtschreibprüfung
http://www.ooo-portal.de/ - Deutsches ""OpenOffice.org-Portal""
http://de.openoffice.info/ - Deutsches ""OpenOffice.org-Forum""
http://www.ooowiki.de/ - Deutschsprachiges Wiki zu ""OpenOffice.org""
In Base integrierte [[http://hsqldb.org/ HSQL-Datenbank-Engine]] (engl.)
[[http://api.openoffice.org/ OpenOffice.org API (Application Programming Interface)]] (engl.)
[[http://docs.sun.com/app/docs/doc/819-1326/ Das StarOffice 8 Programmierhandbuch für BASIC]] (gilt auch für ""OpenOffice.org 3"").
[[http://www.starbasicfaq.de/ Starbasic/OpenOffice.org Basic]] FAQ, Referenz, Benutzeranleitung und Forum.
[[http://www.beanshell.org/ Beanshell]] (engl.)
[[http://www.kostenlose-javascripts.de/javascript-tutorials/tutorials.html Javascript-Tutorial]]
[[http://www.reportlab.org/docs/PythonReferenz.pdf Referenzhandbuch zur Programmiersprache Python]]


======Kategorien======

[[CategoryTutorials]]
Valid XHTML :: Valid CSS: :: Powered by WikkaWiki