Revision [1415]

Last edited on 2011-03-06 22:49:26 by RudiS [+Link]
Additions:
~- Slackware 13
LibreOffice
======Links======
Deletions:
~- Slackware 13.0


Revision [1387]

Edited on 2009-09-15 15:41:19 by RudiS [+ OOo aktualisieren]
Additions:
=====""OpenOffice.org"" aktualisieren=====
In OOo Menü **Extras ""→"" Optionen ""→ OpenOffice.org →"" Online Update** kann die automatische Suche nach Updates aktiviert, und das Download-Zielverzeichnis z. B. auf ## /tmp ## eingestellt werden.
Danach kann von dort, oder von OOo Menü **Hilfe ""→"" Suche nach Updates** die Suche gestartet werden.
Zur Installation des Updates siehe oben "Manuelle Installation aus RPMs".
(direkt aus dem Online-Update-Dialog heraus funktioniert die Installation nicht.)


Revision [1369]

Edited on 2009-08-30 22:25:43 by RudiS [Korrekturen zu Slackware 13.0]
Additions:
~- Slackware 13.0
""OpenOffice.org 3"" wird nach ## /opt/openoffice.org3/ ## installiert.
In OOo Menü **Extras ""→"" Optionen ""→"" Internet ""→"" Email** als Email-Programm je nach gewünschtem Email-Programm z. B. ## kmail ## oder ## thunderbird ## eintragen.
In OOo Menü **Vorlagen und Dokumente ""→"" Verwalten ""→"" Adressbuch ""→"" Adressdatenquelle ""→"" Thunderbird** wählen. Danach Tabelle auswählen und die Feldzuordnungen bearbeiten.
In OOo Menü **Vorlagen und Dokumente ""→"" Verwalten ""→"" Adressbuch ""→"" Adressdatenquelle ""→"" KDE Adressbuch** wählen. Danach Tabelle auswählen und die Feldzuordnungen bearbeiten.
In OOo Menü **Extras ""→"" Optionen ""→"" ""OpenOffice.org"" ""→"" Java ""→"" Class Path** die Datei (Java-Archiv) ## /usr/lib/java/lib/ext/mysql-connector-java-5.1.8-bin.jar ## hinzufügen.
In ""OpenOffice.org"" **Modul Datenbank ""→"" JDBC** aufrufen. Dort eingeben:
Falls beim Verbindungstest der JDBC-Treiber nicht geladen werden kann, dann sollten die Schritte JDBC-Treiber anmelden und ""MySQL-Datenbank"" anmelden zuerst als root ausgeführt werden. Danach klappt es auch als normaler User.
Deletions:
""OpenOffice.org 3"" wird nach ///opt/openoffice.org3/// installiert.
In OOo Menü **Extras -> Optionen -> Internet -> Email** als Email-Programm je nach gewünschtem Email-Programm z. B. ## kmail ## oder ## thunderbird ## eintragen.
In OOo Menü **Vorlagen und Dokumente -> Verwalten -> Adressbuch -> Adressdatenquelle -> Thunderbird** wählen. Danach Tabelle auswählen und die Feldzuordnungen bearbeiten.
In OOo Menü **Vorlagen und Dokumente -> Verwalten -> Adressbuch -> Adressdatenquelle -> KDE Adressbuch** wählen. Danach Tabelle auswählen und die Feldzuordnungen bearbeiten.
In OOo Menü **Extras -> Optionen -> ""OpenOffice.org"" -> Java -> Class Path** die Datei (Java-Archiv) ///usr/lib/java/lib/ext/mysql-connector-java-5.1.8-bin.jar// hinzufügen.
In ""OpenOffice.org"" **Modul Datenbank -> JDBC** aufrufen. Dort eingeben:


Revision [1360]

Edited on 2009-08-16 00:12:32 by RudiS [Links hinzugefügt]
Additions:
In Base integrierte [[http://hsqldb.org/ HSQL-Datenbank-Engine]] (engl.)
[[http://api.openoffice.org/ OpenOffice.org API (Application Programming Interface)]] (engl.)
[[http://docs.sun.com/app/docs/doc/819-1326/ Das StarOffice 8 Programmierhandbuch für BASIC]] (gilt auch für ""OpenOffice.org 3"").
[[http://www.starbasicfaq.de/ Starbasic/OpenOffice.org Basic]] FAQ, Referenz, Benutzeranleitung und Forum.
[[http://www.beanshell.org/ Beanshell]] (engl.)
[[http://www.kostenlose-javascripts.de/javascript-tutorials/tutorials.html Javascript-Tutorial]]
[[http://www.reportlab.org/docs/PythonReferenz.pdf Referenzhandbuch zur Programmiersprache Python]]


Revision [1351]

Edited on 2009-08-13 08:12:27 by RudiS [Auf OOo3 aktualisiert, Einrichtung hinzugefügt]
Additions:
~- Slackware 12.2
[[http://www.openoffice.org OpenOffice.org]] (engl.) ist ein freies Office-Paket, das aus einer Kombination verschiedener Programme zur Textverarbeitung, Tabellenkalkulation, Präsentation und zum Zeichnen besteht. Ein Datenbankprogramm und ein Formeleditor sind ebenfalls enthalten.
======Manuelle Installation aus RPMs======
=====""OpenOffice.org 2"" aus den RPMs installieren=====
(der einfachste, aber vielleicht nicht der beste Weg)
**Hinweis:**
Wenn schon mal eine manipulierte ""OpenOffice.org-Version"" installiert war (gilt insbesondere für die Ubuntu-Version von ""OpenOffice.org""), wird empfohlen im home-Verzeichnis die Datei //~/.openoffice.org// durch umbenennen, verschieben oder löschen unkenntlich zu machen. Anderenfalls kann nach der Installation der Programmstart eines Moduls (Writer, Calc, ...) in endlosen Dokumentwiederherstellungsversuchen abstürzen.
Leider wird Open Office nur noch als RPM oder DEB angeboten. Mit beidem kann man als Slackware Benutzer nicht wirklich viel Anfangen. Zum Glück gibt es aber nützliche kleine Programme die uns doch den Einsatz von rpm-Paketen auch ohne rpm ermöglichen.
Dort als gewünsches System "Linux x86 (rpm)" wählen. Aktuelle Version und Server deiner Wahl.
Nun zunächst als root einloggen (am besten erst mit Strg + Alt + F6 auf ein VT wechseln) und in das Verzeichnis wechseln, in dem z. B. die Datei OOo_2.1.0_LinuxIntel_install_de.tar.gz liegt. Den Inhalt der Datei auspacken (##tar -xfz OOo_2.1.0_LinuxIntel_install_de.tar.gz##). Jetzt hat man ganz viele rpm-Dateien.
=====Nachtrag zu ""OpenOffice.org 3""=====
Das Installationstutorial trifft auch auf ""OpenOffice.org 3"" zu.
Für ""OpenOffice.org 3"" wird laut offizieller [[http://de.openoffice.org/doc/setupguide/index.html Installationsanleitung]] JRE (Java-Runtime-Environment) Version 1.6.0 oder höher empfohlen. Diese ist im jeweils aktuellen Download-File //Linux x86 (inkl JRE + Installer)// bereits enthalten.
""OpenOffice.org 3"" wird nach ///opt/openoffice.org3/// installiert.
======Installation mit Hilfe eines ""SlackBuild""-Skriptes======
======""OpenOffice.org"" mit anderen Anwendungsprogrammen verwenden======
=====Email-Programm zum Versenden von Dokumenten als Anhang einstellen=====
In OOo Menü **Extras -> Optionen -> Internet -> Email** als Email-Programm je nach gewünschtem Email-Programm z. B. ## kmail ## oder ## thunderbird ## eintragen.
=====Adressbuch anmelden=====
====Thunderbird-Adressbuch anmelden====
In OOo Menü **Vorlagen und Dokumente -> Verwalten -> Adressbuch -> Adressdatenquelle -> Thunderbird** wählen. Danach Tabelle auswählen und die Feldzuordnungen bearbeiten.
====KDE-Adressbuch anmelden====
In OOo Menü **Vorlagen und Dokumente -> Verwalten -> Adressbuch -> Adressdatenquelle -> KDE Adressbuch** wählen. Danach Tabelle auswählen und die Feldzuordnungen bearbeiten.
**Siehe auch:** [[http://www.ooowiki.de/AdressBuch Adressbuch anmelden]] in ooowiki.de
=====JDBC-Treiber anmelden=====
**Voraussetzung für die Anmeldung des JDBC-Treibers:** JdbcTreiberInstallieren
In OOo Menü **Extras -> Optionen -> ""OpenOffice.org"" -> Java -> Class Path** die Datei (Java-Archiv) ///usr/lib/java/lib/ext/mysql-connector-java-5.1.8-bin.jar// hinzufügen.
Danach ""OpenOffice.org"" komplett beenden und neu starten.
=====""MySQL""-Datenbank anmelden=====
**Voraussetzung für die Anmeldung einer ""MySQL-Datenbank"":** MySQLinBetriebNehmen
In ""OpenOffice.org"" **Modul Datenbank -> JDBC** aufrufen. Dort eingeben:
Datenquellen-URL: ## jdbc:mysql://localhost/<Datenbankname> ##
JDBC-Treiberklasse: ## com.mysql.jdbc.Driver ##
Anschließend noch auf der nächsten Seite die Authentifizierungsdaten eingeben.
======Siehe auch======
http://de.openoffice.org/ - Deutsche Projektseite
[[http://de.openoffice.org/downloads/komponenten.html Zusätzliche Komponenten]] - Vorlagen, Dokumentation, Rechtschreibprüfung
http://www.ooo-portal.de/ - Deutsches ""OpenOffice.org-Portal""
http://de.openoffice.info/ - Deutsches ""OpenOffice.org-Forum""
http://www.ooowiki.de/ - Deutschsprachiges Wiki zu ""OpenOffice.org""
======Kategorien======
Deletions:
=====Manuelle Installation aus RPMs=====
[[http://www.openoffice.org Open Office]] 2.1 aus den RPMs installieren. (der einfachste, aber vielleicht nicht der beste Weg)
Leider wird Open Office seit einiger Zeit nur noch als RPM oder DEB angeboten (Stand März 2007). Mit beidem kann man als Slackware Benutzer nicht wirklich viel Anfangen. Zum Glück gibt es aber nützliche kleine Programme die uns doch den Einsatz von rpm-Paketen auch ohne rpm ermöglichen.
Dort als gewünsches System "Linux x86 (rpm)" wählen. Version 2.1.0 und Server deiner Wahl.
Nun zunächst als root einloggen (am besten erst mit Strg + Alt + F6 auf ein VT wechseln) und in das Verzeichnis wechseln, in dem die Datei OOo_2.1.0_LinuxIntel_install_de.tar.gz liegt. Den Inhalt der Datei auspacken (##tar -xfz OOo_2.1.0_LinuxIntel_install_de.tar.gz##). Jetzt hat man ganz viele rpm-Dateien.
=====Installation mit Hilfe eines ""SlackBuild""-Skriptes=====
==Kategorien==


Revision [875]

Edited on 2007-04-01 08:42:49 by MreimeR [Hinweis auf slackbuilds.org eingefügt.]
Additions:
=====Manuelle Installation aus RPMs=====
=====Installation mit Hilfe eines ""SlackBuild""-Skriptes=====
Auf http://www.slackbuild.org/ gibt es ein geeignetes Skript, um aus den RPMs ein anständiges Slackware-Paket zu bauen:
http://www.slackbuilds.org/repository/office/openoffice.org/


Revision [874]

Edited on 2007-03-28 19:07:06 by MreimeR [rpm2tgz immer als root ausführen (sonst falsche Rechte). Info zu Symlink nach /usr/bin eingefügt]
Additions:
Nun zunächst als root einloggen (am besten erst mit Strg + Alt + F6 auf ein VT wechseln) und in das Verzeichnis wechseln, in dem die Datei OOo_2.1.0_LinuxIntel_install_de.tar.gz liegt. Den Inhalt der Datei auspacken (##tar -xfz OOo_2.1.0_LinuxIntel_install_de.tar.gz##). Jetzt hat man ganz viele rpm-Dateien.
Der nächste Schritt ist ein (manchmal) nützliches kleines Slackware Programm, rpm2tgz. ;) Mit einem einfachen "##rpm2tgz *.rpm##" werden jetzt aus all den rpm-Dateien Slackware Pakete erstellt.
Als nächstes kann man die rpm-Dateien mit "##rm *.rpm##" löschen.
Nun mit ##installpkg *.tgz## die ganzen Pakete installieren lassen. Open Office wird dann nach /opt/openoffice.org2.1/ installiert.
Für den schnellen Aufruf von der Konsole lohnt ein Symlink nach /usr/bin:
##ln -s /opt/openoffice.org2.1/program/soffice /usr/bin##
Je nach Windowmanager oder Desktop können jetzt noch Verküpfungen angelegt werden.
Die Startdateien von Open Office, zu denen man dann Verknüpfungen anlegen kann, findet man in /opt/openoffice.org2.1/program/
Deletions:
Nach dem herunterladen der OOo_2.1.0_LinuxIntel_install_de.tar.gz in das Verzeichnis wechseln, in dem die Datei liegt.
Den Inhalt der Datei auspacken (tar xfz OOo_2.1.0_LinuxIntel_install_de.tar.gz). Jetzt hat man ganz viele rpm-Dateien.
Der nächste Schritt ist ein (manchmal) nützliches kleines Slackware Programm, rpm2tgz. ;) Mit einem einfachen "rpm2tgz *" werden jetzt aus all den rpm-Dateien Slackware Pakete erstellt.
Als nächstes kann man die rpm-Dateien mit "rm *.rpm" löschen.
Nun mit su root werden und mit installpkg *.tgz die ganzen Pakete installieren lassen. Open Office wird dann nach /opt/openoffice.org2.1/ installiert.
Je nach Windowmanager oder Desktop müssen jetzt noch verküpfungen angelegt werden.
Die Startdateien von Open Office zu denen man dann Verknüpfungen anlegen kann, findet man in /opt/openoffice.org2.1/program/


Revision [873]

Edited on 2007-03-26 21:12:42 by ToniCE [rpm2tgz immer als root ausführen (sonst falsche Rechte). Info zu Symlink nach /usr/bin eingefügt]
Additions:
Die Startdateien von Open Office zu denen man dann Verknüpfungen anlegen kann, findet man in /opt/openoffice.org2.1/program/
Deletions:
Die Startdatei von Open Office zu denen man dann Verknüpfungen anlegen kann, findet man in /opt/openoffice.org2.1/program/


Revision [872]

Edited on 2007-03-26 21:12:07 by ToniCE [rpm2tgz immer als root ausführen (sonst falsche Rechte). Info zu Symlink nach /usr/bin eingefügt]
Additions:
[[http://www.openoffice.org Open Office]] 2.1 aus den RPMs installieren. (der einfachste, aber vielleicht nicht der beste Weg)
Als erstes natürlich Open Office von hier laden: [[http://de.openoffice.org/downloads/quick.html http://de.openoffice.org/downloads/quick.html]]
Deletions:
Open Office 2.1 aus den RPMs installieren. (der einfachste, aber vielleicht nicht der beste Weg)
Als erstes natürlich Open Office von hier laden: http://de.openoffice.org/downloads/quick.html


Revision [871]

The oldest known version of this page was created on 2007-03-26 21:10:26 by ToniCE [rpm2tgz immer als root ausführen (sonst falsche Rechte). Info zu Symlink nach /usr/bin eingefügt]
Valid XHTML :: Valid CSS: :: Powered by WikkaWiki